Hot stall, Rev lag

Welcome to the ZXRworld forum.

Moderator: Moderators

Post Reply
Graeme1198
Posts: 6
Joined: Sat Sep 05, 2020 6:40 pm
My Bike: Zxr400

Hot stall, Rev lag

Post by Graeme1198 » Wed Oct 07, 2020 3:47 pm

Hi guys.

Working on a friends bike, it’s had an issue with hot starting/cutting out.

1989 H1
Micron exhaust

I’ve adjusted all his valve clearances to spec, new plugs, his carbs had been previously cleaned but I’ve no proof of that mind you.

Fuel pumps working, carbs are at 2.5 turns out.

Took it out for a spin today, got it up to temp and it was riding great but wasn’t really down low in the Rev range apart from a few lights.

Get it back home and it cuts out, wouldn’t start again without choke. Checked I had fuel tried reserve etc.

Now when it’s running and blipping the throttle it will do nothing and then rev after it’s released, almost like a delay. Once it’s kind of picked up it will be responsive.

I’ve attached a video if anyone’s got any ideas, thinking maybe the cruddy pilot circuit or possible vacuum leak, float levels?...

https://youtu.be/9twp5VCsdZc

User avatar
banner001
Track day God
Track day God
Posts: 2496
Joined: Sat Sep 24, 2011 3:27 pm
My Bike: ZXR400 L4
Location: Nuneaton

Re: Hot stall, Rev lag

Post by banner001 » Wed Oct 07, 2020 7:26 pm

I would remove the pilot jets and see if the very small central hole is plugged with dirt.

Air leak is easy enough to test with some easy start. Though that usually causes the revs to hang, not bog down.

Float heights you can check when you remove the carbs for the pilot jets.
UK ZXR400 L3 (1993) - Fully restored and on the roads, my green beast!
JPN ZXR250 A2 (1990) - Revs to 19,200rpm... 'nuff said :smt003

Graeme1198
Posts: 6
Joined: Sat Sep 05, 2020 6:40 pm
My Bike: Zxr400

Re: Hot stall, Rev lag

Post by Graeme1198 » Wed Oct 07, 2020 8:03 pm

Thanks for the reply, I think I’ll whip those bowls off and have a look. It’s a strange one when you snap the throttle it will increase revs after the butterfly’s are back to the original position....

Been having a look round for carb boots just Incase it is those, can’t seem to find any atm. The ones on the bike don’t seem in bad condition at all but I’ll spray a little round them while it’s running and see if I get a Rev change.

Post Reply