Wemoto clutch cable

Moderator: Moderators

Post Reply
Bobby Dazzler
Posts: 8
Joined: Mon Apr 16, 2012 6:43 pm
My Bike: Honda Bros 650

Wemoto clutch cable

Post by Bobby Dazzler » Sun Apr 27, 2014 1:03 pm

I am having difficulty adjusting my clutch cable.

I have adjusted it both ends but it either stalls as I feed the clutch out or it pulls away with the lever on the bar. It is a new cable ordered through wemoto.

Anyone else had problems or can anyone provide a pic of either end of their cable on the bike so I can check mine.

Thanks

User avatar
RedexRobB
Site Admin
Site Admin
Posts: 7212
Joined: Fri Aug 30, 2002 7:37 pm
My Bike: ZXR400L3
Location: Ipswich, Suffolk

Re: Wemoto clutch cable

Post by RedexRobB » Sun Apr 27, 2014 5:49 pm

Have you possibly messed with the clutch switch during fitting ?

User avatar
banner001
Track day God
Track day God
Posts: 2205
Joined: Sat Sep 24, 2011 3:27 pm
My Bike: ZXR400 L4
Location: Nuneaton

Re: Wemoto clutch cable

Post by banner001 » Mon Apr 28, 2014 9:16 am

the only way it can pull away when the lever is up against the bar is if the cable is too long, in other words, even pulling the cable back is not disengaging the clutch, which means that you have either adjusted your clutch cable incorrectly, or you have been given/ordered the wrong cable for your model.

what model is your zxr400, l or h, the cables are different sizes and the OEM h is no longer available, maybe wemoto got them mixed up?
UK ZXR 400 L4
UK ZXR 400 L3 track bike
1989 FZR 1000 EXUP-R streetfighter

Bobby Dazzler
Posts: 8
Joined: Mon Apr 16, 2012 6:43 pm
My Bike: Honda Bros 650

Re: Wemoto clutch cable

Post by Bobby Dazzler » Mon Apr 28, 2014 8:47 pm

I have a L5.

Thanks for the replies.

Post Reply