L2 speedo removal (now misfiring ?)

Moderator: Moderators

Post Reply
OZZYSBIKES
Posts: 7
Joined: Mon Jul 17, 2017 8:59 pm
My Bike: Triumph street triple

L2 speedo removal (now misfiring ?)

Post by OZZYSBIKES » Thu Dec 28, 2017 3:15 pm

HI

I have just posted in the wanted section for a CDI unit for my sons L2 track bike, well.................................... after reading a few threads on misfiring, restrictions, cdi,s etc, etc etc ! I have had a germ of a thought, is it possible that by removing the speedo and unplugging the electrical connection to it I have somehow caused the misfiring problem ? only other thing that was done in between two track days was to remove the air box and increase the main jet size,

anyone that knows these bikes better than I do, especially the minefield of the electrics might know that I have dropped a goolie ! any imparted knowledge much appreciated,

I am going to get the bike back together and plug the speedo back in (remake the connector) to try my theory out, I think it must be something to do with the speedo removal (and electrical connection) as I cannot see why apart from lighting a mechanical speedo would have electrics to it other than to send info back to the ecu (CDI),

The CDI fitted to the bike is a blue one part number 21119-1331 and as far as I was aware that one doesn't restrict the bike ?

OZZYSBIKES
Posts: 7
Joined: Mon Jul 17, 2017 8:59 pm
My Bike: Triumph street triple

Re: L2 speedo removal (now misfiring ?)

Post by OZZYSBIKES » Thu Dec 28, 2017 3:31 pm

I have just been reading about the rev limiter dodge for the H models but this bike is a L model (L2 I think) but it does have the KPH speedo on it originally so it looks more and more like I have caused the rev limiter to activate,

The thing is do I do the same dodge as with the H models I.E. just put a 10K ohm 1 watt resistor between the pink wire going to the CDI and earth or is it different on the L model ?

Help appreciated in saving me some time sussing it out for myself

User avatar
banner001
Track day God
Track day God
Posts: 2150
Joined: Sat Sep 24, 2011 3:27 pm
My Bike: ZXR400 L4
Location: Nuneaton

Re: L2 speedo removal (now misfiring ?)

Post by banner001 » Fri Dec 29, 2017 10:38 am

Hi, you have 2 possible options, I would first put the resistor between pink wire and ground and see if that solves it (from memory removing the clocks only allows the bike to rev to 10k in all gears), or you fit a 21119-1332 blue M marked cdi as these have no speed/rpm restrictions, though you might need to alter the connections from your loom into the cdi.

I've done a guide in the electrical section showing you how to convert a standard loom into a track only loom, as well as the modifications to make it total loss too.
UK ZXR 400 L4
UK ZXR 400 L3 track bike
1989 FZR 1000 EXUP-R streetfighter

OZZYSBIKES
Posts: 7
Joined: Mon Jul 17, 2017 8:59 pm
My Bike: Triumph street triple

Re: L2 speedo removal (now misfiring ?)

Post by OZZYSBIKES » Fri Dec 29, 2017 4:47 pm

Thanks Banner,

I want to leave the bike so that when I sell it (early next year) it can easily put back on the road so don't want to end up with a race bike only loom,

I have got the parts to put the resistor inline so will give that a go and keep the speedo handy so that I can just plug speedo back in and see if both or either cure the high rpm misfire !

Post Reply