Bike won't go over 90mph

Moderator: Moderators

Post Reply
carlos4
Posts: 7
Joined: Tue Aug 04, 2009 10:01 pm
My Bike: zxr l9 400cc
Location: hull

Bike won't go over 90mph

Post by carlos4 » Fri Sep 25, 2009 8:36 pm

Been out on bike to day and when got to 90 it just didn't want t go any faster throttle was fully open . Plus the bike don't seem quick enough for a 400 . Any ideas ppm? Cheers

User avatar
CaNsA
zxr400 oc member
zxr400 oc member
Posts: 1741
Joined: Sat Nov 29, 2008 4:02 pm
My Bike: ZX6R F1
Location: Liverpool

Re: Bike won't go over 90mph

Post by CaNsA » Fri Sep 25, 2009 8:38 pm

fuel > Air mixture is well off. mine done the same until i covered up 1/3 of the snorkel
Moderator & Skilled Ban Hammer Operator!
Has this forum helped you out? Say thanks by donating some of your hard earned cash towards running costs.

:: <=-LOADED TELLY BOXES - NO CONTRACT - NO SUBSCRIPTION - PM ME-=> ::

carlos4
Posts: 7
Joined: Tue Aug 04, 2009 10:01 pm
My Bike: zxr l9 400cc
Location: hull

Re: Bike won't go over 90mph

Post by carlos4 » Fri Sep 25, 2009 8:41 pm

So I'm gathering that's on the carbs. Another thing it does is when stop at lights revs stay pretty high for a few mins then calm down around 3k does this when warm

carlos4
Posts: 7
Joined: Tue Aug 04, 2009 10:01 pm
My Bike: zxr l9 400cc
Location: hull

Re: Bike won't go over 90mph

Post by carlos4 » Fri Sep 25, 2009 8:43 pm

I have put this post on here as I didn't know if the bike was restricted or not !

User avatar
RedexRobB
Site Admin
Site Admin
Posts: 7212
Joined: Fri Aug 30, 2002 7:37 pm
My Bike: ZXR400L3
Location: Ipswich, Suffolk

Re: Bike won't go over 90mph

Post by RedexRobB » Fri Sep 25, 2009 9:20 pm

it doesnt sound like its restricted, sound like you have an air leak going by the hanging revs when you pull up to a stop. The inlet rubbers are usually the cause for that, a bit of sealant between the inlet and the engine block usually cures it, or if you really fussy new o'rings. Might also want to check the carb clamps are done up tightly too, no going any faster than 90 suggests its more than a small air leak. Also check the airbox is sitting flush on top of the carbs. :smt001

Jeppo
L-plate hell
L-plate hell
Posts: 279
Joined: Sat Sep 06, 2008 10:54 pm

Re: Bike won't go over 90mph

Post by Jeppo » Sat Sep 26, 2009 9:41 am

The hanging revs do suggest an air leak, but i wouldn't have thought that would account for it not going over 90.... This does sound like it could be a 33hp restriction, although even then they tend to be able to go more than 90. With a strong tail wind my old vfr would just about do 90 restricted AND running on 3 cyclinders.

Check all ure downpipes are getting hot to make sure it is running 4...

User avatar
extonyg
zxr400 oc member
zxr400 oc member
Posts: 407
Joined: Tue May 12, 2009 9:40 pm
My Bike: zxr 400 L1 uk
Location: Portsmouth

Re: Bike won't go over 90mph

Post by extonyg » Sat Sep 26, 2009 9:56 am

sounds like to me it is restricted.........does it rev out fully in the lower gears?? as the restrictor plates can also cause air leaks causing the hanging revs and lower top end.

User avatar
Mad Phil
Posts: 91
Joined: Wed Jun 24, 2009 6:39 pm
My Bike: Hayabusa, Ducati 996SPS
Location: Stoney Stanton, Leicestershire

Re: Bike won't go over 90mph

Post by Mad Phil » Sat Sep 26, 2009 3:50 pm

Whats it rev to off load 10k or 12.5K ?

carlos4
Posts: 7
Joined: Tue Aug 04, 2009 10:01 pm
My Bike: zxr l9 400cc
Location: hull

Re: Bike won't go over 90mph

Post by carlos4 » Sat Sep 26, 2009 7:25 pm

It revs to around 12 . Checked the Cdi unit and it's blue with an m on so won't be that. And it's a uk bike. It seems to struggle after 70. Really jerky. Will have to try some were on Monday to have a look at the carbs . 1&2 nd all seem good and no limitnon that.

bendog66
L-plate hell
L-plate hell
Posts: 475
Joined: Sun Oct 12, 2008 11:12 am
My Bike: ZXR400 L4, ZX6R F1 track
Location: Chesterfield

Re: Bike won't go over 90mph

Post by bendog66 » Sat Sep 26, 2009 9:17 pm

agree with cansa. Sounds like it needs a Dynojet kit or similar. Does full throttle work at all?

User avatar
Mad Phil
Posts: 91
Joined: Wed Jun 24, 2009 6:39 pm
My Bike: Hayabusa, Ducati 996SPS
Location: Stoney Stanton, Leicestershire

Re: Bike won't go over 90mph

Post by Mad Phil » Sun Sep 27, 2009 9:08 am

How long have you had the bike & has it always been like it ?

User avatar
extonyg
zxr400 oc member
zxr400 oc member
Posts: 407
Joined: Tue May 12, 2009 9:40 pm
My Bike: zxr 400 L1 uk
Location: Portsmouth

Re: Bike won't go over 90mph

Post by extonyg » Sun Sep 27, 2009 12:23 pm

has it got uk carbs on it?they havent been replaced for 30mm ones have they??
mine is a uk spec bike and revs to 14k......
start with all the basics though.......check fuel pump, air leaks, spark plugs etc

Post Reply