Zxr400 engine will not rev

Welcome to the ZXRworld forum.

Moderator: Moderators

Post Reply
Trevor moon
Posts: 2
Joined: Tue Aug 06, 2019 3:04 pm
My Bike: Zxr 400

Zxr400 engine will not rev

Post by Trevor moon » Tue Aug 06, 2019 5:26 pm

Hi I have recently acquired a 1999 zxr 400 that has only covered 6,500 miles,but has spent the last 10 years unused in a less than dry garage,having restored the whole bike,I have found a massive problem.When the engine is started from cold(choke never used)it runs perfectly until it reaches running temp,then it will not idle or rev over 3000rpm,have replaced plugs,finding the old ones black and sooty,new plugs are now black and sooty,just the same(getting too much fuel from primary jets),I havechecked all diaphragms needles jets,all perfect and correct,changed fuel float needles and seats,separated carbs ultrasoniclly cleaned them,whilst stripped checked for fuel leakage from choke sliders,no leaks,set fuel level to mark on carb,checked for leaks from all float chambers,none,compressions 135 psi all cylinders,all valve clearances are set correctly,no air leaks anywhere ,new fuel tap.Does anyone have the faintest idea what could be the problem?(engine will only start and run with idle mixture screws screwed right in)but still will not rev over 3000rpm?

User avatar
banner001
Track day God
Track day God
Posts: 2364
Joined: Sat Sep 24, 2011 3:27 pm
My Bike: ZXR400 L4
Location: Nuneaton

Re: Zxr400 engine will not rev

Post by banner001 » Tue Aug 06, 2019 7:44 pm

Screwing the mixture screws all the way in will allow almost no fuel mixture to enter the engine, so this means that either you have a massive blockage in the airbox or engine inlets, or you have fuel leaking into the engine probably past the float bowl seals.

I would carefully remove the carbs from the bike, keep the fuel pump attached to the carbs and fire up the bike... See if any fuel emerges from the carbs... There should be no fuel at all.

Sounds like it's running massively rich to me as you need no choke to fire up from cold and gets worse as the bike warms and the plugs are very dark.

What needles you running, stock or dynojet?
If DJ needles what are your clip positions?
What's the float heights on all the carbs?
What main jets are you using?
Have the pilot jets been swapped for larger ones?
Has it been raced, is it on a ram Air box or standard, have the air corrector jets been sealed where the airbox sits?
UK ZXR 400 L4
UK ZXR 400 L3 track bike
1989 FZR 1000 EXUP-R streetfighter

Trevor moon
Posts: 2
Joined: Tue Aug 06, 2019 3:04 pm
My Bike: Zxr 400

Re: Zxr400 engine will not rev

Post by Trevor moon » Sun Aug 11, 2019 4:21 pm

All the needles and jets are std, the air box and exhaust are std,the air jets have been jetted with carb cleaner and are all clear,I have had carbs on the bench hooked up to the bikes fuel pump and left it running for 30 mins ,no leaks,fuel levels are all set to the mark on the side of the no 4 carb ( throttle cable end) ?True the the thing is very rich ,but how can the extra fuel be getting in,I can only guess that the air bleed tubes to the primary circuits are blocked,but all 4 of them?and I have blown ,air,fuel,carb cleaner,and many other fluids through them ,and every time the fluid comes out of the jet in the float chamber,the outlet in the venturi, next to the butterfly,and the mixture adjuster screw(when removed).Nothing makes any sense ?

Post Reply