Getting very hot very quick and a poor idle...

Moderator: Moderators

Post Reply
Jimmy8998
Posts: 2
Joined: Sun May 24, 2020 7:02 pm
My Bike: ZXR400L
Location: Plymouth

Getting very hot very quick and a poor idle...

Post by Jimmy8998 » Tue Jun 09, 2020 7:38 pm

My bike (ZXR400L 1993) is getting really hot really quick. I think the problem is linked to a high idle. About 2100rpm (should be sitting at about 1200 +⁵⁰). I have to set it to that on the "throttle adjust screw" because it cuts out any lower than that. I think the need for a high idle to prevent it cutting out is from my carbs being a little dirty from using poor quality fuel recently. I initially tried to rectify the problem the lazy way with redx thinking it will clean out any dirt and grim from the carbs however I put to much in so it was obviously really lean and burning high. that was when the heating problem started. I have carb cleaner on it's way and am planning on getting around it as soon as.

The heating problem occurs at low town speed. Even just passing through some random little village on a ride will seriously rack up the temp especially sat at lights or a junction. (Its fine caneing it down the lanes, I guess because of the air flow)
This makes me think it's nothing to do with the idle because normal rpm at like 30/40mph would be above or around 2000rpm.
The fan is kicking in but all that is doing is confirming to me it's getting really hot. I need to point out this is a recent thing, the fan hasn't really been need before...
The radiator has seen better days... but it's not tooo bad.

Wanted to know if anyone has had this sort of problem and what you did to rectify it?
If you've not had this problem then what would you do?
I think I've covered everything.
Any and all suggestions are welcome.
Many thanks
Jimmy

User avatar
banner001
Track day God
Track day God
Posts: 2443
Joined: Sat Sep 24, 2011 3:27 pm
My Bike: ZXR400 L4
Location: Nuneaton

Re: Getting very hot very quick and a poor idle...

Post by banner001 » Wed Jun 10, 2020 7:06 am

These bikes do run hot, but basically it's going to be one of two things, poor cooling ability or head gasket going.

I would drop all your coolant and flush the full system, then I would remove the radiator and flush that separately. Fill with fresh coolant, bleed and see how that goes.

If you think the radiator is in decent condition then I would replace the head gasket.

As for the carbs they are gonna need a full strip down not just carb cleaner, you need to inspect the small pilot jets for dirt, remember to measure all the "as is" settings so you can put it back together correctly.
UK ZXR400 L3 (1993) - Fully restored and on the roads, my green beast!
JPN ZXR250 A2 (1990) - Revs to 19,200rpm... 'nuff said :smt003

Jimmy8998
Posts: 2
Joined: Sun May 24, 2020 7:02 pm
My Bike: ZXR400L
Location: Plymouth

Re: Getting very hot very quick and a poor idle...

Post by Jimmy8998 » Wed Jun 10, 2020 10:11 am

Thank you I'll get on with that

Post Reply